opentrack issue

Moderators: Uros, Tom, OXO

Post Reply
Friggitotti
Posts: 45
Joined: Mon May 15, 2017 2:46 pm

opentrack issue

Post by Friggitotti » Sat Jul 07, 2018 3:31 pm

hi all,
I have installed opentrack on my pc because I use it in games such as il-2 sturmovik and DCS.
With opentrack installed even if it is closed and not running I can not use my hat switch on my joystick to move the view inside condor (1 and 2), this because I prefer not using opentrack for condor.
Is there any way to avoid this ? If yes I would be glad if anyone could tell me how.
thank you, Friggitotti

User avatar
timbaeyens
Posts: 262
Joined: Mon Sep 12, 2005 1:31 am

Re: opentrack issue

Post by timbaeyens » Thu Jul 12, 2018 2:34 pm

opentrack puts a path to a .dll in the registry and a game/sim loads that .dll provided as part of opentrack.

I assume you're using the freetrack protocol for Output within Opentrack? Go to protocol settings using the hammer button and select the disable on program exit checkbox. From now on, you need to start opentrack first before running any games/sims. If/once you get used to running opentrack with any sims, you can disable the option and the registry path will persist. That option clears the path once opentrack is stopped.
TT

Marpilot
Posts: 71
Joined: Thu Aug 16, 2018 2:40 am

Re: opentrack issue

Post by Marpilot » Tue Dec 10, 2019 9:56 am

Hi,I can't turn off opentrack for Condor 2 , as I want it only for DCS.
This solution is not working for me :(
Anyone in similar situation?

AstirAl
Posts: 9
Joined: Sun Jul 26, 2020 8:47 pm

Re: opentrack issue

Post by AstirAl » Sun Jul 26, 2020 8:55 pm

Opentrack emulates the commercial NaturalPoint TrackIR system, and leaves behind a registry key indicating that this is available. Condor apparently detects that key and disables the hat switch.

Unfortunately, the current version of OpenTrack does not provide any way (that I can see) to remove it through the GUI.

To fix:
  • Open start menu and search for "Registry editor". Run it.
  • Remove the following section (or rename it for easy replacement later): HKEY_CURRENT_USER\Software\NaturalPoint

User avatar
JBlyth
Posts: 189
Joined: Thu Apr 23, 2020 12:10 pm

Re: opentrack issue

Post by JBlyth » Tue Jul 28, 2020 6:43 am

I changed to FaceTrackNoIR to solve the problem. Nothing else worked for me with OpenTrack.

Cheers
John in Sunny Carnarvon - Western Australia

tomrob999
Posts: 5
Joined: Mon Dec 20, 2010 9:38 pm

Re: opentrack issue

Post by tomrob999 » Mon Jan 31, 2022 12:01 am

Try this Registry file to remove the dll path

Open Notepad and copy what is below into it. Save As NaturalPoint - Remove.reg somewheer where you know to find the file.

Run if you want to remove the enrty that opentrack creates. opentrack will recreate the registery key again everytime when run.

Thus if you were running opentrack and want to have the hat switch and mouse look back, run the REG file to cleat the PATH.

Registry info starts---

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\SOFTWARE\NaturalPoint]
[HKEY_CURRENT_USER\SOFTWARE\NaturalPoint\NATURALPOINT]
[HKEY_CURRENT_USER\SOFTWARE\NaturalPoint\NATURALPOINT\NPClient Location]
"Path"=""

---Registry info ends

Genchik
Posts: 55
Joined: Tue Dec 18, 2018 4:38 pm
Contact:

Re: opentrack issue

Post by Genchik » Sat Feb 17, 2024 9:03 pm

Thanks for the useful information. This is important for those who use Open Track. The problem is that Condor reacts so painfully to these registry keys. It would be useful for Condor developers to check the “Use OT” box :wink: . In order to be able to use the keyboard or joystick to move the gaze when there is no need for OpenTrack. Or is it temporarily broken, for example.
.
Opps. Hurray, problem solved
I found the necessary checkbox in the OT settings. Here she is. If you install it, OT cleans the registry
Attachments
121.png
121.png (33.3 KiB) Viewed 49 times

Post Reply

Who is online

Users browsing this forum: No registered users