Condor 2 on Linux / Wine issues

Moderators: Uros, Tom, OXO

CSeguinot
Posts: 3
Joined: Fri Nov 13, 2020 6:56 pm

Re: Condor 2 on Linux / Wine issues

Post by CSeguinot » Tue Nov 24, 2020 7:00 pm

Hi
I'm back after a lot of tests.

Without using Lutris, I never succeeded to run Condor on Wine, Ubuntu 18.04 and 20.04, using update vulkan , latest graphics drivers, ppa or patched wine (build from source)

I then tried Lutris and want to thank TonyBalony for his clean procedure. It was my first time with Lutris, it's easy to install, run different wine build, install and test games ...
Condor2 ran on the first try using Lutris !

I'm now in the process of trying to correct small issues.
- Ole error 8004100E (at start, and sometimes at end of lesson and flight). This is a small issue and seems to have no real impact
- activation : asked every time Condor2 is launched, but it seems that it is not needed I can run Condor2 (providing activation key was been given on the earliest run)
- child window issue : this one was never reported by Linux/Wine users, but it is quite annoying.

The child window issue:
When Condor 2 is launched, 3 windows are opened (see screen1.png):
- a Condor2 icon
- a Condor2 main windows (let call it the "parent window")
- a "child window" (flight lesson, activation, setup, free flight... depending on the requested user action). I call it "child window "since it is related to the parent window. The child window must be closed, for the parent window to get focus and the user to select a new action.
It's worst noting that the child window it partly above and partly under its parent window!

My first issue is that the once you click outside the child window , it disappear under its parent window. As the parent window can't be moved, you are not able to reselect the child window. The only solution is to kill Condor2.exe task.

My second and related issue is for flight when trying a lesson. The border of the "child window" is always visible during flight. Surprisingly, I tried to make a screen copy, but this border is not present on it (look like the image is composed of layer, only some being copied!)

Does any one notice this issue and can give any advice or direction to solve it ?
Does anyone could give advice on which Lutris/wine version could solve this? (I used the latest Lutris/Wine 5.21 and tested some others without success)

PS
Regards
And many thank to these post which are valuable for the glider community and pilots.
screen1.png
You do not have the required permissions to view the files attached to this post.

CSeguinot
Posts: 3
Joined: Fri Nov 13, 2020 6:56 pm

Re: Condor 2 on Linux / Wine issues

Post by CSeguinot » Sun Nov 29, 2020 5:28 pm

Hi
I finally got it after 3 weeks trial. I just solved it using a Wine config !!
  • Under Lutris, open "wine configuration" (may be winecfg if not using Lutris)
  • Select "graphics" tab
  • Uncheck "Allow the window manager to control the windows"
I tested different wine version from 5.5 to Lutris 5.7 : all the one I tested where working.

Help this can help others.

Regards, Christophe

User avatar
BOD1
Posts: 1834
Joined: Mon Aug 07, 2006 2:45 pm
Location: Brittany, France
Contact:

Re: Condor 2 on Linux / Wine issues

Post by BOD1 » Fri Dec 11, 2020 3:09 pm

Hello, Christophe, cos, flix, KuCoOs, TonyBalony, pucki, jfsoar, bwduncan and others, could you please have a look viewtopic.php?f=29&t=20342 and tell me if you have a clue?
Thank you :)
Image
Please use this button to send me a PM, Forum messaging is too limited.
Image

Post Reply